Skip to end of metadata
Go to start of metadata

2.4.1 Saving Files from the Data Manager

The Sci2 Tool supports various image output formats. When in GUESS, use 'File> Export Image' to export the current view or the complete network in diverse file formats such as jpg, png, raw, pdf, gif, etc.
To save image files created outside of GUESS, such as Circular Hierarchies or Geospatial Visualization, right-click on the PostScript file in the data manager and then click 'save'. Select 'PostScript' and then save the file to your desired directory.


Figure 2.14: Saving a PostScript File

Adobe PostScript files can be converted to .pdf files using Adobe Distiller and viewed in Adobe Acrobat.

Alternately, PostScript files can be viewed in special interpreters, such as GSview, which requires Ghostscript software:
     Ghostscript 9.01: http://pages.cs.wisc.edu/~ghost/doc/GPL/gpl901.htm
     GSview 4.9: http://pages.cs.wisc.edu/~ghost/gsview/get49.htm

Once you have created a visualization with Sci2 you will want to share it with others. Some of the Sci2 visualizations, such as Map of Science via Journals and Temporal Bar Graph, have built-in legends. However, most networks generated with GUESS or Gephi will not have these legends. Fortunately, it is fairly easy to create your own legend for any network visualization. This workflow will document the steps that you need to follow in order to create your own legend. For this tutorial we will be using Inkscape, an open-source vector graphics editor. You can download the tool here.

For this tutorial we will be saving the visualizations from GUESS and Gephi as PDF files and opening them in Inkcape. Vector images, such as PDFs or SVGs, are ideal because they will scale nicely without pixelation. In other words, your visualization will look clean and professional regardless of whether you mount it to the Web for viewing with a mobile device or print it off as a poster to share with others at a conference.

2.4.2 Creating Legends for Visualizations

Watch the video of this workflow:



2.4.2.1 Saving Visualizations from GUESS

Once you have finalized your visualization in GUESS you will need to export the image. Go to "File > Export Image..." and select the location where you want to save the document. Then you will want to choose the file type, in this case PDF. Finally, you can rescale the image by selecting export complete graph and setting a different value for the rescale image parameter:

This will output an image 56060px by 39226px. In this case we are creating a very large image, but you can rescale the image to your desired size. Make sure to leave GUESS open on your machine because you may need to refer back to the original graph while creating legend!

2.4.2.2 Saving Visualizations from Gephi

Once the visualization has been finalized in Gephi it can be exported from the Preview. In the lower left-hand corner of the tool there will be a button to export the visualization:


Select the file format you wish to save the visualization as. In this instance we will be saving the visualization as a PDF file.

Make sure to leave Gephi open on your machine because you may need to refer back to the original graph while creating legend!

2.4.2.3 Opening the visualization in Inkscape

The first step is to open the PDF file you have saved from either Gephi or GUESS in Inkscape. To open files in Inkscape go to "File > Open..."

Select the file PDF you saved and click open and this will load your network visualization in Inkscape.

2.4.2.4 Resizing the Inkscape document to fit the visualization

The first step you might need to do is to re-size document so that your visualization fits. You can change the size of the Inkscape document by going to "File > Document Properties..."

Adjust the height and width of the document to help your visualization fit better:

2.4.2.5 Ungrouping the Visualization

When the PDF is opened in Inkscape all of the various components of the visualization, in this case nodes, edges, and labels, will be grouped together. The next step will be to ungroup those components so you can access and edit them individually. To perform an ungroup, first left-click on the graph so the entire image is selected:

Then right-click in the center of the image and select ungroup:

You may have to repeat this step several times to completely ungroup all the different elements of the visualization.

2.4.2.6 Editing the Labels in the Visualization

After you have ungrouped all the elements you may need to move around some of the labels. Occasionally, the labels at the edge of the graph will be cut off when they are exported from GUESS. If this is the case you may need to edit those labels so you can clearly see everything.

Also, some of the labels may appear behind the nodes and the edges, making them difficult to read. If this is the case you can bring the label to the front. Select the label you wish to bring to the front by clicking on it. Then from the menu at the top select "Object > Raise to Top"

Look over the entire graph and make sure all your labels are clearly visible. You may need to refer back to the visualization in GUESS or Gephi to check the labels for certain nodes and make sure all the nodes accurately labeled. If you need to edit existing label text you can do so by selecting the Create and Edit Text Objects tool icon from the tool menu on the left-hand side of the screen or by hitting the F8 key. When using this tool click on the label you wish to edit and change the text.

2.4.2.7 Creating the Legend Titles

The next step is to begin creating your legend. How you create the legend depends on the values for attributes of the nodes and edges in your network. This is the information you want to convey to those who see your visualization. In the following steps we will be working with the network we generated from the florentine.nwb file in section 2.8 Visualizing Data with Sci2 on the Sci2 wiki . As you may remember, the nodes have been sized based on the wealth of the family represented by the node and colorized based on the number of priorates a particular family held. The edges have been colorized based on the type of relationship that connects two families: business tie or marriage. So, based on these attributes we are going to create titles and subtitles for our legend:

Using the Create and Edit Text Objects tool:  you can create titles. For each section of text that you want to display a different font size and color, for example the subtitles, you will need to create a separate text object. If you want to edit the text you can use the tool bar at the top of the tool:

With this toolbar you can change the font and size of the text, as well as other attributes. If  you want to change the color of the text you can do so by using the color pallet at the bottom of the tool:

2.4.2.8 Creating Legend Symbols

The next step is to create different symbols and associate those symbols with vales to convey more information about your visualization. Think about the legend on maps, these help readers decipher what they are looking at and determine distance. Similarly, the legends we will create for this visualization will help readers find which families are the most influential in this dataset, based on wealth, priorates, and number of connections with other families.

In order to determine the values for our symbols we will need to refer back to the original visualization. In GUESS you can use the information window to view these values. Simply hover your mouse over the node or edge you wish to examine and view its properties in the information window:

==--

To find the values for attributes of nodes and edges in Gephi, view the graph in the Overview window of Gephi. Then use the  tool and label the edges and the nodes:

Once you have chosen which attribute to label the nodes or edges with, they can be applied by clicking the label tool: . It is a good idea to label nodes and edges separately. In other words, apply the node labels and then remove them before you apply the edge labels. Otherwise, the graph will be too crowed with node and edge labels to identify values to use in your legend. Typically, it can be difficult to identify edge attribute values because there are so many edges to be labeled that it can become crowded very quickly. One trick when dealing with a lot of attribute labels is to use the Gephi filters to filter either nodes or edges by certain attributes. To pull up the filter window in Gephi go to "Window > Filters" at the top of the tool:

The filter window will appear at the right-hand side of the tool. You can choose to filter edges by the edge weight (number of co-authored papers) attribute by dragging the edge weight filter into the queries section below:

Use the slide bar at the very bottom of the window to filter the edges. Drag the bar and then click filter:

To create the symbols in the legend, we will be using differently sized circles (representing nodes) to convey the wealth of the families in this network.

First, find the family (node) with the most wealth. In the case of this network it is the Strozi family with 146 thousand lira. The Strozi node will serve as the highest point on the scale. Next, find the smallest node, or the least wealthy family, to serve as the lowest point of the scale. In this case it is the Pucci family with 3 thousand lira. Finally, you will need to find a node to serve as the middle point on the scale. In the case of this network we will use the Barbadori family with 55 thousand lira.

Once you have identified these nodes you can select them in the Inkscape file:

==

It is helpful to zoom in on the image and make sure you are actually selecting the border around the node. Once you have made the selection, copy the selection by right-clicking and copying the selection (or by using the Ctrl+C keyboard shortcut). Then paste the copy below the first title "Nodes Size & Color." If you are unable to accurately copy and paste the circles from the network you can create your own using the circle tool and manually creating the symbols:

When the you have created the symbols for the nodes you may need to change the stroke and fill colors so that all the symbols are the same. To change the stroke color and the fill color for any object in the graph simply use the selection tool:  to identify the object and then select "Object > Fill and Stroke..." in the tool menu. This will bring up the pallet you need to edit the fill and stroke for objects:

The next step will be to create a gradient scale for the color of  the nodes. Using the rectangle tool:   create a rectangle below the node symbols:

Now we need to fill each rectangle with the range of colors we applied to the nodes and the range of colors we applied to the edges, respectively. Select the first rectangle, under the Node Size & Color title. You will notice that in the fill tab there is the option to fill an object using a linear gradient:

Once you have selected the linear gradient, make sure the rectangle tool:  is select and the rectangle should appear like this:

Select the square at the left-side of the blue line:

 

Then use the eyedropper tool:  and select the color from a node at the lowest limit of the scale, the Pucci family node. Repeat this process, select the circle at the right-side of the blue line and use the eyedropper tool to select the color from the largest node, the Strozi family:

The next step is to create three symbols below the "Edge Color" title to represent the three types of relationships in this network. Use the rectangle  tool to create the symbols:

The final step is to label your symbols in your legend using the  text tool:

 

The resulting visualization will look something like this:

 

Now you have created a legend for this visualization! A person who sees your visualization will now be better able to understand exactly what information is meant to be conveyed with this visualization. Feel free to think of other ways to convey the information about the various attributes of you visualization.

 

  • No labels